log in

Advanced search

Message boards : News : New Apps Released!

Author Message
Profile Tom
Volunteer moderator
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2567 - Posted: 16 Jul 2013, 16:19:49 UTC
Last modified: 16 Jul 2013, 16:20:21 UTC

Yesterday we released a new app version for each of our supported platforms. Below are the latest versions:


  • CCL v2.06
  • Java-1.7 v1.03
  • Pypy1.9 v3.04
  • Python-2.7 v1.03
  • R2.15.1 v104 (Linux and Windows only)


The applications were updated to unarchive large packages and libraries into the projects directory, as opposed to the slots directly, once for the lifetime of the archive. This reduces the overhead that is required to unarchive each package into the slots directory, and may reduce the amount of total disk space the project uses at runtime. Please let us know if you notice any problems associated with these new versions.

Profile Tom
Volunteer moderator
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2568 - Posted: 16 Jul 2013, 17:14:16 UTC - in response to Message 2567.

We've already caught and fixed one bug in the Python application for Linux and Mac users. Spaces in pathnames weren't escaped properly and it was causing our unarchive process to fail. If you received an error it would resemble the following:

18:24:05 (97455): wrapper: running 7za.exe (x -o/Library/Application Support/BOINC Data/projects/mindmodeling.org/python2.7_1.1_env -y python2.7.7z) dyld: DYLD_ environment variables being ignored because main executable (/bin/ps) is setuid or setgid app exit status: 0x200


This fix applies to any new workunits that are created.[/i]

NATE1
Send message
Joined: 2 Jun 11
Posts: 2
Credit: 7,687
RAC: 11
Message 2569 - Posted: 17 Jul 2013, 9:25:01 UTC

3: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'gtools'



??????

Profile Tom
Volunteer moderator
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2570 - Posted: 17 Jul 2013, 15:02:08 UTC - in response to Message 2569.
Last modified: 17 Jul 2013, 15:03:58 UTC

One of our researchers has tried to include an R package called 'gtools' in their model, but it isn't available. I've spoken with this researcher, and he has confirmed that his model isn't actually using the API (otherwise it would crash) and shouldn't be the cause of any workunit units failing.

Message boards : News : New Apps Released!


Main page · Your account · Message boards


Copyright © 2017 MindModeling.org