log in

Advanced search

Message boards : Number crunching : Upload error but still got credit ???

Author Message
David Ball
Send message
Joined: 9 Dec 12
Posts: 6
Credit: 141,068
RAC: 0
Message 2412 - Posted: 20 Dec 2012, 7:48:50 UTC

I got the following error

12/19/2012 11:59:23 PM | MindModeling@Beta | Starting task MindModeling-279-50d25f6e646cc_1 using ccl_wrap version 189 (sse2) in slot 0
12/20/2012 12:55:01 AM | MindModeling@Beta | Computation for task MindModeling-279-50d25f6e646cc_1 finished
12/20/2012 12:55:01 AM | MindModeling@Beta | Starting task MindModeling-279-50d267292461a_0 using ccl_wrap version 189 (sse2) in slot 0
12/20/2012 12:55:03 AM | MindModeling@Beta | Started upload of MindModeling-279-50d25f6e646cc_1_0
12/20/2012 12:55:05 AM | MindModeling@Beta | [error] Error reported by file upload server: invalid signature
12/20/2012 12:55:05 AM | MindModeling@Beta | Giving up on upload of MindModeling-279-50d25f6e646cc_1_0: permanent upload error


http://mindmodeling.org/result.php?resultid=4655812

It looks like It did validate and get credit though. It used 3,050.69 CPU seconds and seems to have run several models although it got some compiler errors at the beginning of stderr_txt.

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2413 - Posted: 21 Dec 2012, 16:33:15 UTC - in response to Message 2412.
Last modified: 21 Dec 2012, 16:33:32 UTC

The compiler warnings in the stderr.txt file would not be the cause of this error. It's possible that the "invalid signature" error is indicating that the results file either does not exist or was deleted, but at this point I don't have enough information to determine the root cause. Is this error occurring frequently, or at very least, has it occurred more than once?

David Ball
Send message
Joined: 9 Dec 12
Posts: 6
Credit: 141,068
RAC: 0
Message 2420 - Posted: 22 Dec 2012, 7:09:05 UTC - in response to Message 2413.

That only happened once. Now all of the WUs are failing very quickly with this as the stderr output:

Stderr output

<core_client_version>7.0.42</core_client_version>
<![CDATA[
<message>
- exit code 195 (0xc3)
</message>
<stderr_txt>
wrapper: starting
00:52:47 (6456): wrapper: running ../../projects/mindmodeling.org/1.88_windows_intelx86_ccl.exe (-I ccl.image -l letf.lisp -b -- windows_intelx86 mm_config_file.txt in.txt)
Can't allocate required TLS indexes.
First available index value was 31
app exit status: 0x1
00:52:48 (6456): called boinc_finish

</stderr_txt>
]]>


Could this have something to do with my upgrading to BOINC core client 7.0.42 since the previous error ?

Profile SunBadger*
Send message
Joined: 25 Feb 12
Posts: 10
Credit: 1,105,617
RAC: 0
Message 2427 - Posted: 2 Jan 2013, 1:00:27 UTC

Happy New Year Tom, and may this year bring you all you desire! Mind will not pick up ACT-278_5068e2dc02593. I have had it for about 2 weeks and have asked several time for it to be picked up. All request to no avail. My time limit runs out on the 1st and I would rather not lose the credit. Thank you for your held. Jake

____________

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2433 - Posted: 3 Jan 2013, 16:14:34 UTC - in response to Message 2420.
Last modified: 9 Jul 2013, 13:31:05 UTC

That only happened once. Now all of the WUs are failing very quickly with this as the stderr output:

Stderr output

<core_client_version>7.0.42</core_client_version>
<![CDATA[
<message>
- exit code 195 (0xc3)
</message>
<stderr_txt>
wrapper: starting
00:52:47 (6456): wrapper: running ../../projects/mindmodeling.org/1.88_windows_intelx86_ccl.exe (-I ccl.image -l letf.lisp -b -- windows_intelx86 mm_config_file.txt in.txt)
Can't allocate required TLS indexes.
First available index value was 31
app exit status: 0x1
00:52:48 (6456): called boinc_finish

</stderr_txt>
]]>


Could this have something to do with my upgrading to BOINC core client 7.0.42 since the previous error ?


See http://mindmodeling.org/forum_thread.php?id=645.

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2434 - Posted: 3 Jan 2013, 16:16:52 UTC - in response to Message 2427.
Last modified: 3 Jan 2013, 16:17:24 UTC

@Sunbadger

How are you asking for the workunit to be "picked up"? Is it via the "Update" button? Could you provide the event log?

Also, are you using the new project URL?

http://mindmodeling.org/

CeSinge
Send message
Joined: 13 Jan 13
Posts: 2
Credit: 0
RAC: 0
Message 2455 - Posted: 13 Jan 2013, 12:01:25 UTC - in response to Message 2434.

Hello,

Is this issue of 'invalid signature' solved in the meantime?
I have it even with BOINC 7.0.28, and for all tasks, as far as I can see.
Or would my issue be different, as you guys seem to say it results from upgrading to a later version (if so, sorry for hijacking). The log entry, in any case, is the same as what was initially posted.
Thank you,

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2459 - Posted: 14 Jan 2013, 16:05:32 UTC

@CeSinge

The 'invalid signature' has not been solved. Could you provide some event log messages? And the contents of your MindModeling project directory.

Tom

CeSinge
Send message
Joined: 13 Jan 13
Posts: 2
Credit: 0
RAC: 0
Message 2462 - Posted: 15 Jan 2013, 9:34:43 UTC - in response to Message 2459.

Tom,

Where should I send the contents of my project directory to? Or how?
I will included logs tomorrow, as I stopped it, given all tasks fail.
F>

Alexander_Borisov
Send message
Joined: 4 Apr 13
Posts: 2
Credit: 258,756
RAC: 0
Message 2510 - Posted: 7 Apr 2013, 18:19:25 UTC

Hi.
The issue is still in place. I've got following log records:

07.04.2013 16:48:33 | MindModeling@Beta | Computation for task MindModeling-435-51604b7898ba0_0 finished 07.04.2013 16:48:37 | MindModeling@Beta | Started upload of MindModeling-435-51604b7898ba0_0_0 07.04.2013 16:48:38 | MindModeling@Beta | [error] Error reported by file upload server: invalid signature 07.04.2013 16:48:38 | MindModeling@Beta | Giving up on upload of MindModeling-435-51604b7898ba0_0_0: permanent upload error


Then I have disabled task suspension during CPU load and problem disappeared.

07.04.2013 22:00:05 | MindModeling@Beta | Computation for task MindModeling-435-516192ff2446b_0 finished 07.04.2013 22:00:10 | MindModeling@Beta | Started upload of MindModeling-435-516192ff2446b_0_0 07.04.2013 22:00:12 | MindModeling@Beta | Finished upload of MindModeling-435-516192ff2446b_0_0


I am using BOINC Manager 7.0.28 (x64) in Windows 7 x64 environment.
It looks like suspend/pause still do not work for the MM tasks.

Regards,
Alexander

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2511 - Posted: 9 Apr 2013, 16:17:14 UTC - in response to Message 2510.
Last modified: 9 Apr 2013, 16:20:33 UTC

It looks like suspend/pause still do not work for the MM tasks.


We have several apps for our project to allow our researchers to run models in their most familair programming language (e.g., Python, Lisp, Java). The previous pause/suspend problems affected our Lisp interpreter, but this new one affects our Python application (and maybe others).

I'll get back to you soon with a solution.

Alexander_Borisov
Send message
Joined: 4 Apr 13
Posts: 2
Credit: 258,756
RAC: 0
Message 2556 - Posted: 25 Jun 2013, 18:32:47 UTC - in response to Message 2511.

Hi.

It looks like suspend/resume error is actual for R wrapper.

25/06/2013 19:15:23 | MindModeling@Beta | Restarting task MindModeling-485-51c994cbab9ae_0 using R2.15.1_wrap version 103 (sse2) in slot 3 25/06/2013 21:00:15 | MindModeling@Beta | Computation for task MindModeling-485-51c994cbab9ae_0 finished 25/06/2013 21:00:20 | MindModeling@Beta | Started upload of MindModeling-485-51c994cbab9ae_0_0 25/06/2013 21:00:24 | MindModeling@Beta | [error] Error reported by file upload server: invalid signature 25/06/2013 21:00:24 | MindModeling@Beta | Giving up on upload of MindModeling-485-51c994cbab9ae_0_0: permanent upload error


Regards,
Alexander Borisov

Profile Tom
Avatar
Send message
Joined: 23 Jun 08
Posts: 490
Credit: 238,767
RAC: 0
Message 2562 - Posted: 9 Jul 2013, 13:33:00 UTC - in response to Message 2556.

Thank you, Alexander. Both Python and R are now known to be causing this problem. I will attempt to replicate.

Message boards : Number crunching : Upload error but still got credit ???


Main page · Your account · Message boards


Copyright © 2021 MindModeling.org