log in

Advanced search

Message boards : Number crunching : Too many apps - please deprecate obsolete apps

Author Message
skgiven
Avatar
Send message
Joined: 6 Oct 12
Posts: 3
Credit: 367,055
RAC: 0
Message 3813 - Posted: 13 Jul 2016, 8:39:05 UTC
Last modified: 13 Jul 2016, 8:49:00 UTC

Run only the selected applications
ACT-R cognitive modeling environment using Steel Bank Common Lisp (Cross Platform): no
ACT-R cognitive modeling environment using Steel Bank Common Lisp (Windows Only): no
ACT-R cognitive modeling environment using Steel Bank Common Lisp (Linux Only): yes
ACT-R cognitive modeling environment using Steel Bank Common Lisp (Mac OS): no
ACT-R cognitive modeling environment using Clozure Common Lisp (Cross Platform): no
ACT-R cognitive modeling environment using Clozure Common Lisp (Windows Only): no
ACT-R cognitive modeling environment using Clozure Common Lisp (Linux Only): yes
ACT-R cognitive modeling environment using Clozure Common Lisp (Mac Only): no
Native Python v2.7 Application (Cross Platform): no
Native Python v2.7 Application (Windows Only): no
Native Python v2.7 Application (Linux Only): yes
Native Python v2.7 Application (Mac Only): no
Native Pypy v1.9 Application (Cross Platform): no
Native Pypy v1.9 Application (Windows Only): no
Native Pypy v1.9 Application (Linux Only): yes
Native Pypy v1.9 Application (Mac Only): no
Native R v2.15.1 Application (Cross Platform): yes
Native [R] v2.15.1 Application (Windows Only): yes
Native [R] v2.15.1 Application (Linux Only): yes
Native Java 1.7 Application (Cross Platform): no
Native Java 1.7 Application (Windows Only): no
Native Java 1.7 Application (Linux Only): yes
Native Matlab Application (Cross Compatible): yes
Native Matlab Application (Linux Only): yes
ACT-R cognitive modeling environment using Steel Bank Common Lisp - Full Node (Cross Platform): yes
ACT-R cognitive modeling environment using Steel Bank Common Lisp - Full Node (Windows Only): yes
ACT-R cognitive modeling environment using Steel Bank Common Lisp - Full Node (Linux Only): yes
ACT-R cognitive modeling environment using Steel Bank Common Lisp - Full Node (Mac OS): no
ACT-R cognitive modeling environment using Clozure Common Lisp - Full Node (Cross Platform): yes
ACT-R cognitive modeling environment using Clozure Common Lisp - Full Node (Windows Only): yes
ACT-R cognitive modeling environment using Clozure Common Lisp - Full Node (Linux Only): yes
ACT-R cognitive modeling environment using Clozure Common Lisp - Full Node (Mac Only): no
Native Python v2.7 Application - Full Node (Cross Platform): no
Native Python v2.7 Application - Full Node (Windows Only): no
Native Python v2.7 Application - Full Node (Linux Only): yes
Native Python v2.7 Application - Full Node (Mac Only): no
Native Pypy v1.9 Application - Full Node (Cross Platform): no
Native Pypy v1.9 Application - Full Node (Windows Only): no
Native Pypy v1.9 Application - Full Node (Linux Only): yes
Native Pypy v1.9 Application - Full Node (Mac Only): no
Native R v2.15.1 Application - Full Node (Cross Platform): no
Native [R] v2.15.1 Application - Full Node (Windows Only): yes
Native [R] v2.15.1 Application - Full Node (Linux Only): yes
Native Java 1.7 Application - Full Node (Cross Platform): no
Native Java 1.7 Application - Full Node (Windows Only): no
Native Java 1.7 Application - Full Node (Linux Only): no
Native Matlab Application - Full Node (Cross Compatible): yes
Native Matlab Application - Full Node (Linux Only): yes
Native Python v2.7 Application (Cross Platform): no
Native Python v2.7 Application (Windows Only): no
Native Python v2.7 Application (Linux Only): no
Native Python v2.7 Application (Mac Only): no
Native Java 1.8 Application (Cross Platform): no
Native Java 1.8 Application (Windows Only): no
Native Java 1.8 Application (Linux Only): no
Native Python v3.4 Application - Full Node (Cross Platform): no
Native Python v3.4 Application - Full Node (Windows Only): no
Native Python v3.4 Application - Full Node (Linux Only): no
Native Python v3.4 Application - Full Node (Mac Only): no
Native Java 1.8 Application - Full Node (Cross Platform): no
Native Java 1.8 Application - Full Node (Windows Only): no
Native Java 1.8 Application - Full Node (Linux Only): no
Native Julia v0.4.5 Application (Cross Platform): yes
Native Julia v0.4.5 Application (Windows Only): yes
Native Julia v0.4.5 Application (Linux Only): yes
Native Julia v0.4.5 Application (Mac Only): no
Native Julia v0.4.5 Application - Full Node (Cross Platform): yes
Native Julia v0.4.5 Application - Full Node (Windows Only): yes
Native Julia v0.4.5 Application - Full Node (Linux Only): yes
Native Julia v0.4.5 Application - Full Node (Mac Only): no

Please remove the obsolete apps from the selection options in Account Preferences. There are far too many:
Preferences for this project MindModeling@Home (Beta) preferences

The two active apps are:
Native Python v2.7 Application (Linux Only)
Native R v2.15.1 Application (Cross Platform)

The apps are also listed in the server_status page.

I didn't find the new (Linux Only) app until I used Ctrl+F to search for it, after referring to the server_status page to see what is available.

TIA

Profile Brandon
Project administrator
Project developer
Project tester
Avatar
Send message
Joined: 5 Jan 15
Posts: 262
Credit: 1,456,117
RAC: 0
Message 3814 - Posted: 13 Jul 2016, 12:45:26 UTC
Last modified: 18 Jul 2016, 16:09:12 UTC

Hello skgiven,

These are actually all the different apps we support. We have modelers who write in various languages and we support these languages and their dependencies with the apps listed.

While currently we are only running the Python and R apps. We may get a new job that uses any of the other apps you have in that list based on its requirements.

Hope this helps and thanks for supporting us,

Brandon

Profile Steve Hawker*
Send message
Joined: 30 Oct 12
Posts: 6
Credit: 109,889
RAC: 0
Message 3817 - Posted: 13 Jul 2016, 23:25:19 UTC - in response to Message 3814.
Last modified: 13 Jul 2016, 23:25:19 UTC

Yes, but some of these apps haven't run in years. I suspect some, perhaps even most, have never been run.

BitcoinUtopia has had at least 103 apps but it only lists the active apps. Thank goodness.

Would it be too much to retire an app if it hasn't run in the last 30 days?

Also, I think one group is for regular and the other for multicore tasks. Could we at least have some idea which is which?

Cheers!!

Profile Brandon
Project administrator
Project developer
Project tester
Avatar
Send message
Joined: 5 Jan 15
Posts: 262
Credit: 1,456,117
RAC: 0
Message 3818 - Posted: 14 Jul 2016, 13:41:52 UTC
Last modified: 14 Jul 2016, 13:41:52 UTC

Let me see what I can do for you guys.

skgiven
Avatar
Send message
Joined: 6 Oct 12
Posts: 3
Credit: 367,055
RAC: 0
Message 3838 - Posted: 22 Jul 2016, 9:09:49 UTC - in response to Message 3818.
Last modified: 22 Jul 2016, 9:09:49 UTC

No change yet, so some suggestions:

Deprecate/archive apps after they have not been used for a month.
Only show active apps (in Preferences for this project).
Highlight active apps, so they are easy to find and select.
Highlight new apps as they become available and announce them in one thread that can be subscribed to.
Auto-enrol crunchers to run any new apps, or give a tick box option to 'run new apps'.
Have one check box to select/deselect all apps, or all active apps.

Good luck,
____________


Message boards : Number crunching : Too many apps - please deprecate obsolete apps


Main page · Your account · Message boards


Copyright © 2018 MindModeling.org